Is Elsevier, the academic publishing house, really stuck in the 1990’s?

This other day, when trying to mark-up a final proof of a paper that my colleagues and I had accepted to an Elsevier journal, I had a flash-back to the 1990’s – you know, the good old days when not only was this a common sight on websites:

But, where websites actually were designed (and, only worked mostly correctly on) a very specific version of a very specific web-browser.

Fortunately, the 1990’es came to an end, web-designers grew up, and the world moved on to following standards and platform independence…

…except, apparently, Elsevier – which is still stuck in the 1990’es, it seems. For this was the message I was met with at their website:

Other than being reflexive of Elsevier being stuck in the 1990’es, it’s a rather offensive message to suggest that “Firefox 35.0+, Chrome 40.0+ or IE 11.0+” is an upgrade to what browser I might be using (which browser I am using is immaterial).

Worse: changing the User-Agent that my browser presents to one of those “recommended” does cause the Elsevier proof central to load – only to get stuck half-way through.

So, it’s (apparently) not just a matter of Elsevier not having completely tested their web-app to be standards compliant and platform independent – but, they really are stuck in the 1990’es…the era of using non-standard, browser-specific APIs.

 

WP Facebook Auto Publish Powered By : XYZScripts.com
%d bloggers like this: